summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Abramov <levenson@mmer.org>2024-02-11 19:28:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commit062a4a49dbfaacdbc3bc9f9abc08e87f35b808f3 (patch)
tree83b8106e2756786eb2ee7b86ffeae59797352aca
parent9cdcf7c6f909cec5af8a34bb4f2226e1ab507ee7 (diff)
gnu: Add go-dario-cat-mergo.
This is a new version of go-github-com-imdario-mergo. It was renamed and now used as dario.cat/mergo in tests and other places. * gnu/packages/golang.scm (go-dario-cat-mergo): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I10cf6c962441535493889820543d29a9a9b20e98
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d3e4249c4d..4e46c70d81 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8080,6 +8080,27 @@ recursively any exported one. It also won't merge structs inside
maps (because they are not addressable using Go reflection).")
(license license:bsd-3)))
+(define-public go-dario-cat-mergo
+ (package
+ (inherit go-github-com-imdario-mergo)
+ (name "go-dario-cat-mergo")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/imdario/mergo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "037k2bd97vnbyhn2sczxk0j6ijmv06n1282f76i3ky73s3qmqnlf"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:unpack-path "dario.cat/mergo"
+ #:import-path "dario.cat/mergo"))
+ (native-inputs
+ (list go-gopkg-in-yaml-v3))))
+
(define-public go-github-com-masterminds-sprig
(package
(name "go-github-com-masterminds-sprig")