summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-07 23:32:25 +0100
committerChristopher Baines <mail@cbaines.net>2023-09-27 12:08:01 +0100
commit07a9f57a69d3f8f0bd4d1f6a666c36d846b3cdce (patch)
tree44f3f2620e71822b4b91a1eda28d244aef527e40
parent20e9fd2bcdcde97ac49ad5f0d37b9f8946f68e46 (diff)
gnu: python-stdatamodels: Update to 1.8.0.
* gnu/packages/astronomy.scm (python-stdatamodels): Update to 1.8.0. [propagated-inputs]: Remove python-jsonschema. [native-inputs]: Remove python-pytest-openfiles. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fb501e421c..783f328c4d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2526,13 +2526,13 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(define-public python-stdatamodels
(package
(name "python-stdatamodels")
- (version "1.7.1")
+ (version "1.8.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "stdatamodels" version))
(sha256
(base32
- "0d7a27myl3xgri3z7yx26mr4dpqnlfhdh5i2ql2miwymi0mx3ij5"))))
+ "003h3f07aqf6s24ivwnps81n2h51k545b236s75l8ppvjrm45xfq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2546,13 +2546,11 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(propagated-inputs (list python-asdf
python-asdf-astropy
python-astropy
- python-jsonschema
python-numpy
python-psutil))
(native-inputs (list python-crds
python-pytest
python-pytest-doctestplus
- python-pytest-openfiles
python-scipy
python-semantic-version
python-setuptools-scm))