summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-03-21 19:02:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-28 17:04:29 +0200
commit0a5c2816ea3715529cdc4c68a78eab03ab291752 (patch)
tree6b60b226b3565d2863c0a96bf1b54b5009590a9f
parent8e994ea51239c9b1664cb343be578ef7a052f886 (diff)
gnu: Add r-cycombine.
* gnu/packages/bioconductor.scm (r-cycombine): New variable.
-rw-r--r--gnu/packages/bioconductor.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55d397e5cf..ffa38fda3a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10066,6 +10066,49 @@ and to both short and long sequence reads.")
cluster count and membership by stability evidence in unsupervised analysis.")
(license license:gpl2)))
+;; This is the latest commit and it solves a bug from the latest release.
+(define-public r-cycombine
+ (let ((commit "f18504bc83ff5daee2b5eb4b28f09abdaaa66698") (revision "1"))
+ (package
+ (name "r-cycombine")
+ (version (git-version "0.2.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/biosurf/cyCombine")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fiwnik8iahg01732fik85xhz359x32f1xc59h443pdf7jancskm"))))
+ (properties `((upstream-name . "cyCombine")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-cytolib
+ r-dplyr
+ r-flowcore
+ r-ggplot2
+ r-knitr
+ r-kohonen
+ r-magrittr
+ r-purrr
+ r-rcolorbrewer
+ r-readr
+ r-readxl
+ r-stringr
+ r-sva
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/biosurf/cyCombine")
+ (synopsis "Integration of single-cell cytometry datasets")
+ (description
+ "This package provides a method for combining single-cell cytometry
+datasets, which increases the analytical flexibility and the statistical power
+of the analyses while minimizing technical noise.")
+ (license license:expat))))
+
(define-public r-cytolib
(package
(name "r-cytolib")