summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-31 14:50:10 +0200
committerAndreas Enge <andreas@enge.fr>2013-03-31 14:50:10 +0200
commit0a92b5b30a1701ca6e96e729041b305c057dac37 (patch)
tree0a0f2bc3715d39d866d30819e01e138e3a131782
parentbd8c5d5b02d33ed5952a7d093298611cadfa5818 (diff)
gnu: freetype: Make include file ft2build.h work without changing the CPATH
of dependent packages. * gnu/packages/fontutils.scm (freetype): Add link include/freetype to include/freetype2/freetype.
-rw-r--r--gnu/packages/fontutils.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 551d4ac167..14f8250357 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -38,6 +38,20 @@
(sha256 (base32
"0gpcz6swir64kp0dk3rwgqqkmf48b90dqgczdmznjjryhrahx9r9"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let ((install (assoc-ref %standard-phases 'install))
+ (include (string-append (assoc-ref outputs "out") "/include")))
+ (apply install args)
+ ;; Unravel one directory, since ft2build.h includes directly from
+ ;; freetype/, not freetype2/freetype; this is announced in the file
+ ;; to be changed in a future release.
+ (symlink (string-append include "/freetype2/freetype")
+ (string-append include "/freetype"))))
+ %standard-phases)))
(synopsis "Freetype, a library to render fonts")
(description
"Freetype is a library that can be used by applications to access the