summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2024-06-14 14:00:29 +0400
committerAndrew Tropin <andrew@trop.in>2024-06-14 14:00:29 +0400
commit0beb0dbfe036763e7b5d6c999fe2b3fc89faa6cb (patch)
tree78ad2aa3a342b186114f7079e31898327a840af9
parentb72fdac20061a882b1eeda5ed0e5e27bb1dec205 (diff)
gnu: Add emacs-org-margin.
* gnu/packages/emacs-xyz.scm (emacs-org-margin): New variable. Change-Id: I48dfd476c5d557d12f63efe52ccf5c08476f79ab
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 49292880fa..da4a2340fe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39195,6 +39195,45 @@ and text properties. The package styles headlines, keywords, tables and
source blocks.")
(license license:gpl3+)))
+(define-public emacs-org-margin
+ (let* ((commit "4013b59ff829903a7ab86b95593be71aa5c9b87d")
+ (revision "0"))
+ (package
+ (name "emacs-org-margin")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rougier/org-margin")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13x5568yfqm1lfmy29vcii2bdkjxjygmhslbr0fwgm2xq9rn63yv"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda _
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (rename-file "README.info" "org-margin.info")
+ (install-file "org-margin.info"
+ (string-append #$output "/share/info")))))))
+ (native-inputs (list texinfo))
+ (license license:gpl3+)
+ (home-page "https://github.com/rougier/org-margin")
+ (synopsis "Outdent headlines in emacs org-mode")
+ (description "@code{org-margin} mode allows to outdent org headlines by
+moving leading stars into the margin and transform them into markers depending
+on the chosen style."))))
+
(define-public emacs-pyimport
(let ((commit "a6f63cf7ed93f0c0f7c207e6595813966f8852b9")
(revision "0"))