summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2021-09-27 22:08:41 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-28 12:05:46 +0200
commit0c6145e591e9f381b39a8e9b8c1cd023502b390e (patch)
tree0704b394ea357b9071f77d75c486a6c1eb53db2d
parent1623e6023b9b2cd3dbcb663404067717ba6445f1 (diff)
gnu: emacs-base16-theme: Add themes to output.
* gnu/packages/emacs-xyz (emacs-base16-theme)[arguments]: Add build directory themes to #:include. Add a phase to move them to the appropriate place. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e862cd2873..c9f50294fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8139,6 +8139,24 @@ answers.")
(sha256
(base32 "01w89g413s1da6rf94y1xnhw79cjy2bqb01yfjs58cy492cm0vr6"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^build\\/.*\\.el$"
+ %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'mv-themes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (use-modules (ice-9 regex))
+ (let* ((out (assoc-ref outputs "out"))
+ (theme-dir (string-append (elpa-directory out) "/build")))
+ (for-each (lambda (theme)
+ (rename-file
+ theme
+ (regexp-substitute #f
+ (string-match "build\\/" theme)
+ 'pre 'post)))
+ (find-files theme-dir "\\.el$"))
+ (delete-file-recursively theme-dir)))))))
(home-page "https://github.com/belak/base16-emacs")
(synopsis "Base16 color themes for Emacs")
(description