summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-23 21:41:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-28 21:07:49 -0400
commit0c6586df3bd6e3a42fcf273605d2714ed5dc626f (patch)
tree51d5c311aad7545da18d79eda3299385c1e71237
parent28d27ddd3dbd0cde763c73ca7eda79f4b3da8660 (diff)
gnu: python-numpy: Skip 'test_rint_big_int' test.
* gnu/packages/python-xyz.scm (python-numpy) [phases]{check}: Skip the 'test_rint_big_int' test.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12a5bfa8dd..ca4d7f9cf4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5686,7 +5686,11 @@ include_dirs = ~:*~a/include~%" #$(this-package-input "openblas"))))))
;; These tests may fail on 32-bit systems (see:
;; https://github.com/numpy/numpy/issues/18387).
"not test_float_remainder_overflow "
- "and not test_pareto"
+ "and not test_pareto "
+ ;; The 'test_rint_big_int' test fails on older
+ ;; x86_64 CPUs such as the Core 2 Duo (see:
+ ;; https://github.com/numpy/numpy/issues/22170).
+ "and not test_rint_big_int "
;; These tests seem to fail on machines without
;; an FPU is still under investigation upstream.
;; https://github.com/numpy/numpy/issues/20635