summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 05:04:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:38 +0200
commit0cdc984147b45399199336511fe2e1118f2b7599 (patch)
treeeb3bc7262f8da91cab1193a1f4f0725653612321
parent41e24ace7de6910605668cbf641827a4ffcf8aea (diff)
gnu: brasero: Embed growisofs from dvd+rw-tools input.
* gnu/packages/gnome.scm (brasero)[arguments]: Rename the 'embed-growisofs phase to 'embed-growisofs-reference. Get its growisofs file name from the dvd+rw-tools input, not WHICH.
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a8eb41c464..18c6018d69 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -300,11 +300,12 @@
"/lib/girepository-1.0"))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'embed-growisofs
+ (add-before 'configure 'embed-growisofs-reference
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "plugins/growisofs/burn-growisofs.c"
- (("\"growisofs") (string-append "\"" (which "growisofs"))))
- #t)))))
+ (let ((dvd+rw-tools (assoc-ref inputs "dvd+rw-tools")))
+ (substitute* "plugins/growisofs/burn-growisofs.c"
+ (("(\")(growisofs)" _ prefix command)
+ (string-append prefix dvd+rw-tools "/bin/" command)))))))))
(propagated-inputs
`(("hicolor-icon-theme" ,hicolor-icon-theme)))
(native-inputs