summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 22:40:30 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 23:08:25 +0000
commit0e8f7ee3a95011dd9ebdc99e0f3b754160524b5d (patch)
treee77fcf4ba2f0f93bad61d3bc43d9ff21d3d9533e
parentf10a02bdbfaf12702593b3ebc15ca45f72bd712c (diff)
gnu: go-github-com-nbrownus-go-metrics-prometheus: Adjust inputs.
* gnu/packages/golang-xyz.scm (go-github-com-nbrownus-go-metrics-prometheus): Adjust inputs. [propagated-inputs]: Remove go-github-com-stretchr-testify. [native-inputs]: Add go-github-com-stretchr-testify. Change-Id: I9c409fe88e11273e79809772001b73ffa4ed7afa
-rw-r--r--gnu/packages/golang-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cc522a69b0..c7670ef887 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1623,10 +1623,11 @@ very fast, and tries to be entropy pool friendly.")
(base32 "1kl9l08aas544627zmhkgp843qx94sxs4inxm20nw1hx7gp79dz0"))))
(build-system go-build-system)
(arguments '(#:import-path "github.com/nbrownus/go-metrics-prometheus"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
(propagated-inputs
- (list go-github-com-stretchr-testify
- go-github-com-rcrowley-go-metrics
- go-github-com-prometheus-client-golang))
+ (list go-github-com-prometheus-client-golang
+ go-github-com-rcrowley-go-metrics))
(home-page "https://github.com/nbrownus/go-metrics-prometheus")
(synopsis "Prometheus support for go-metrics")
(description