summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-24 13:12:35 -0400
committerLeo Famulari <leo@famulari.name>2016-05-25 11:50:20 -0400
commit0e9bc883b428ca7721d9bbfe7089648c1f221d14 (patch)
tree9c52fd8dc1f1f31da0cee2602ba84fea0e0e4f29
parentc99bf9b2ea24bcd2f8498121f65618ff967a9140 (diff)
gnu: fuse: Update to 2.9.6.
* gnu/packages/linux.scm (fuse): Update to 2.9.6. [home-page]: Update home-page URL.
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ed8ef8becf..f1c4c7342a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1293,18 +1293,15 @@ processes currently causing I/O.")
(define-public fuse
(package
(name "fuse")
- (version "2.9.5")
+ (version "2.9.6")
(source (origin
(method url-fetch)
- (uri (let ((version-with-underscores
- (string-join (string-split version #\.) "_")))
- (string-append
- "https://github.com/libfuse/libfuse/"
- "releases/download/fuse_" version-with-underscores
- "/fuse-" version ".tar.gz")))
+ (uri (string-append "https://github.com/libfuse/libfuse/releases/"
+ "download/fuse-" version
+ "/fuse-" version ".tar.gz"))
(sha256
(base32
- "1dfvbi1p57svbv2sfnbqwpnsk219spvjnlapf35azhgzqlf3g7sp"))))
+ "0szi2vlsjxg03y4ji51jks34p269jqj5ify6l0ajsqq6f6y8pd0c"))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(arguments
@@ -1340,7 +1337,7 @@ processes currently causing I/O.")
(("-DFUSERMOUNT_DIR=[[:graph:]]+")
"-DFUSERMOUNT_DIR=\\\"/var/empty\\\"")))
%standard-phases)))
- (home-page "http://fuse.sourceforge.net/")
+ (home-page "https://github.com/libfuse/libfuse")
(synopsis "Support file systems implemented in user space")
(description
"As a consequence of its monolithic design, file system code for Linux