summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-22 09:48:50 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-22 14:02:43 +0100
commit0f1f4bf8c540ebde78221c7255a31bc7d71c4432 (patch)
treeff5f0434b6905827e0075da5050f95014becb68f
parent614a7610dab88f5124f2837e70ff878861ef2d8d (diff)
gnu: keepassxc: Update to 2.7.0.
* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.0. [arguments]<#:phases>: Skip failing test. [inputs]: Add BOTAN, MINIZIP and PCSC-LITE. test
-rw-r--r--gnu/packages/password-utils.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 0e5f63e1be..3bf1779ea8 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2017, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2017, 2020-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2022 Marius Bakke <marius@gnu.org>
@@ -81,6 +81,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages libffi)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
#:use-module (gnu packages multiprecision)
@@ -129,7 +130,7 @@ human.")
(define-public keepassxc
(package
(name "keepassxc")
- (version "2.6.6")
+ (version "2.7.0")
(source
(origin
(method url-fetch)
@@ -137,7 +138,7 @@ human.")
"/releases/download/" version "/keepassxc-"
version "-src.tar.xz"))
(sha256
- (base32 "1qm4a1k11vy35mrzbzcc7lwlpmjzw18a2zy7z93rqa4vqcdb20rn"))))
+ (base32 "19va0a9r5px7cbx1ixawaaxrkpfgigb9g81z6h1ngk84164pdgl3"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((guix build cmake-build-system)
@@ -149,6 +150,13 @@ human.")
"-DWITH_XC_UPDATECHECK=NO")
#:phases
(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Fails with "TestCli::testClip() Compared values are not the
+ ;; same". That test also requires a phase with (setenv
+ ;; "QT_QPA_PLATFORM" "offscreen") in order to work.
+ (invoke "ctest" "--exclude-regex" "testcli"))))
(add-after 'install 'wrap-qt
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -158,11 +166,15 @@ human.")
("qttools" ,qttools)))
(inputs
(list argon2
+ botan
libgcrypt
libsodium ; XC_BROWSER
+ libusb
libyubikey ; XC_YUBIKEY
libxi
libxtst
+ minizip
+ pcsc-lite
qrencode
qtbase-5
qtsvg