summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 09:46:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commit0f6902ea79963a2c5d931414103de978a86f9dfd (patch)
tree2d05649ca7f64168fd89b276eee810d5e680f035
parentc00b1760f605255719a525e52c268b222a1f5184 (diff)
gnu: julia-jllwrappers: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-jlwrappers): Move to ... * gnu/packages/julia-jll.scm: ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Register julia-jll.scm
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/julia-jll.scm70
-rw-r--r--gnu/packages/julia-xyz.scm44
3 files changed, 72 insertions, 43 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0c0a6b924a..a5820b5827 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -308,6 +308,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/jrnl.scm \
%D%/packages/jose.scm \
%D%/packages/julia.scm \
+ %D%/packages/julia-jll.scm \
%D%/packages/julia-xyz.scm \
%D%/packages/jupyter.scm \
%D%/packages/kawa.scm \
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
new file mode 100644
index 0000000000..1b63c06312
--- /dev/null
+++ b/gnu/packages/julia-jll.scm
@@ -0,0 +1,70 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages julia-jll)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system julia)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages julia))
+
+(define-public julia-jllwrappers
+ (package
+ (name "julia-jllwrappers")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaPackaging/JLLWrappers.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v7xhsv9z16d657yp47vgc86ggc01i1wigqh3n0d7i1s84z7xa0h"))))
+ (arguments
+ ;; Wants to download stuff
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'custom-override-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Make @generate_wrapper_header take an optional argument that
+ ;; guix packagers can pass to override the default "override"
+ ;; binary path. This won't be needed when something like
+ ;; https://github.com/JuliaPackaging/JLLWrappers.jl/pull/27
+ ;; will be merged.
+ (substitute* "src/wrapper_generators.jl"
+ (("generate_wrapper_header.*")
+ "generate_wrapper_header(src_name, override_path = nothing)\n")
+ (("pkg_dir = .*" all)
+ (string-append
+ all "\n" "override = something(override_path,"
+ "joinpath(dirname(pkg_dir), \"override\"))\n"))
+ (("@static if isdir.*") "@static if isdir($override)\n")
+ (("return joinpath.*") "return $override\n"))
+ #t)))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaPackaging/JLLWrappers.jl")
+ (synopsis "Julia macros used by JLL packages")
+ (description "This package contains Julia macros that enable JLL packages
+to generate themselves. It is not intended to be used by users, but rather is
+used in autogenerated packages via @code{BinaryBuilder.jl}.")
+ (license license:expat)))
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 551f016929..b8ba5bf93f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages julia-jll)
#:use-module (gnu packages maths)
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
@@ -1077,49 +1078,6 @@ external IRs. It can be used with Julia metaprogramming tools such as
Cassette.")
(license license:expat)))
-(define-public julia-jllwrappers
- (package
- (name "julia-jllwrappers")
- (version "1.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaPackaging/JLLWrappers.jl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0v7xhsv9z16d657yp47vgc86ggc01i1wigqh3n0d7i1s84z7xa0h"))))
- (arguments
- ;; Wants to download stuff
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'custom-override-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Make @generate_wrapper_header take an optional argument that
- ;; guix packagers can pass to override the default "override"
- ;; binary path. This won't be needed when something like
- ;; https://github.com/JuliaPackaging/JLLWrappers.jl/pull/27
- ;; will be merged.
- (substitute* "src/wrapper_generators.jl"
- (("generate_wrapper_header.*")
- "generate_wrapper_header(src_name, override_path = nothing)\n")
- (("pkg_dir = .*" all)
- (string-append
- all "\n" "override = something(override_path,"
- "joinpath(dirname(pkg_dir), \"override\"))\n"))
- (("@static if isdir.*") "@static if isdir($override)\n")
- (("return joinpath.*") "return $override\n"))
- #t)))))
- (build-system julia-build-system)
- (home-page "https://github.com/JuliaPackaging/JLLWrappers.jl")
- (synopsis "Julia macros used by JLL packages")
- (description "This package contains Julia macros that enable JLL packages
-to generate themselves. It is not intended to be used by users, but rather is
-used in autogenerated packages via @code{BinaryBuilder.jl}.")
- (license license:expat)))
-
(define-public julia-jpegturbo-jll
(package
(name "julia-jpegturbo-jll")