summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2023-03-31 19:03:46 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-21 10:50:55 +0200
commit1027f1019930b813caf37c1a47ea37f46ebf7ed9 (patch)
treee5528b37a3e5bbce5c87bf7f72d1b1a140565c18
parent2662f074a0d939cd08737b17a8ef0a671c028dec (diff)
gnu: Add alienblaster.
* gnu/packages/games.scm (alienblaster): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/games.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a8c1bb1280..727854afda 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3706,6 +3706,57 @@ enemies in different game modes such as space ball, death match, team death
match, cannon keep, and grave-itation pit.")
(license license:gpl3+))))
+(define-public alienblaster
+ (package
+ (name "alienblaster")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.schwardtnet.de/alienblaster/archives/"
+ "alienblaster-" version ".tgz"))
+ (sha256
+ (base32
+ "104rfsfsv446n4y52p5zw9h8mhgjyrbca8fpyhnxkkasq141a264"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-sdl-paths
+ (lambda _
+ (let ((share (string-append #$output "/share")))
+ ;; Fix name and append path to "SDL_mixer.h"
+ (substitute* "src/Makefile"
+ (("GAME_NAME=alienBlaster") "GAME_NAME=alienblaster")
+ (("SDL_FLAGS=\\$\\(shell sdl-config --cflags\\)" line)
+ (string-append line " -I"
+ #$(this-package-input "sdl-mixer")
+ "/include/SDL")))
+ ;; Substitute relative paths in ".cfg" and source/header files
+ (substitute* (find-files "./cfg")
+ (("(\\./)?images") (string-append share "/images")))
+ (substitute* (list "src/global.h" "src/global.cc")
+ (("./images") (string-append share "/images"))
+ (("./sound") (string-append share "/sound"))
+ (("./cfg") (string-append share "/cfg"))))))
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "alienblaster" (string-append #$output "/bin"))
+ (for-each
+ (lambda (dir)
+ (copy-recursively dir (string-append #$output "/share/" dir)))
+ '("images" "sound" "cfg")))))))
+ (inputs (list sdl sdl-mixer))
+ (home-page "http://www.schwardtnet.de/alienblaster/")
+ (synopsis "Action-loaded 2D arcade shooter game")
+ (description "Alien Blaster is an action-loaded 2D arcade shooter
+game. Your mission in the game is simple: stop the invasion of the aliens by
+blasting them. Simultaneous two-player mode is available.")
+ (license license:gpl2)))
+
(define glkterm
(package
(name "glkterm")