summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvgeny Pisemsky <evgeny@pisemsky.com>2023-06-11 15:10:00 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-11 18:18:29 +0200
commit12178fb7aa3c4a50da5ac54f2b70a258052899c4 (patch)
tree23fdc66f40b6b9173b004e052761490c6c9829ec
parente6da6e3152b01b36d925d8670f1b8c3e1a39ef4b (diff)
gnu: Add emacs-qrencode.
* gnu/packages/emacs-xyz.scm (emacs-qrencode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13cabd7e46..24a4ae169e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34328,6 +34328,33 @@ generate random passwords and insert them into the current buffer. It also
supports generation of phonetic and numeric passwords.")
(license license:artistic2.0)))
+(define-public emacs-qrencode
+ (package
+ (name "emacs-qrencode")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruediger/qrencode-el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yrshahci319lnjdpsksdy11a69k1n91qk9r2zfyhqmng09s6i0y"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:tests? #t
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-l" "qrencode.el"
+ "-l" "qrencode-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/ruediger/qrencode-el")
+ (synopsis "QRCode encoder for Emacs in pure elisp")
+ (description
+ "This package provides two user facing interactive functions, that will encode
+text into a QR Code and show it in a separate buffer.")
+ (license license:gpl3+)))
+
(define-public emacs-csv
(package
(name "emacs-csv")