summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-10 10:05:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:54 +0200
commit129f033b07790a73f940d498239320cc777ffaea (patch)
tree7cf24d8062b05e07b299e459f292b9050099f25c
parent026ed35ddb896829c733f9cc032a7203abe5334c (diff)
gnu: Add texlive-epspdf.
* gnu/packages/tex.scm (texlive-epspdf): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6e5e9de767..bd9b3cd838 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93,6 +93,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages ruby)
#:use-module (gnu packages shells)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages base)
#:use-module (gnu packages gawk)
#:use-module (gnu packages web)
@@ -3212,6 +3213,30 @@ of nodes and the styles of edges, may be adjusted.")
(define-deprecated-package texlive-latex-auxhook texlive-auxhook)
+(define-public texlive-epspdf
+ (package
+ (name "texlive-epspdf")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/info/epspdf.info" "doc/support/epspdf/"
+ "scripts/epspdf/")
+ (base32
+ "0sxn3dff0nxiw68h1kr86rmnc72xkc62fk94j590a4di1lh2firl")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:link-scripts #~(list "epspdf.tlu" "epspdftk.tcl")))
+ (inputs (list tcl tk))
+ (home-page "https://ctan.org/pkg/epspdf")
+ (synopsis "Converter for PostScript, EPS and PDF")
+ (description
+ "Epspdftk.tcl is a GUI PS/EPS/PDF converter. Epspdf.tlu, its
+command-line backend, can be used by itself. Options include grayscaling,
+cropping margins and single-page selection. Some conversion options are made
+possible by converting in multiple steps.")
+ (license license:gpl2)))
+
(define-public texlive-epstopdf
(package
(name "texlive-epstopdf")