summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-10-21 22:11:35 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:46:18 -0500
commit12a09206c3cfa60946689a3b7d857501d2de8116 (patch)
tree469956ad21c52788a9a0a94085b642f1f397a636
parentbba6ad665afda475e2fd9e0a6b51a1dd8adc470d (diff)
gnu: go-github-com-gdamore-tcell-v2: Update to 2.5.3.
* gnu/packages/golang.scm (go-github-com-gdamore-tcell-v2): Update to 2.5.3. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0922ea7462..6c01ba5e7f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6235,28 +6235,26 @@ systems.")
(package
(inherit go-github-com-gdamore-tcell)
(name "go-github-com-gdamore-tcell")
- (version "2.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gdamore/tcell")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ypbl5080q9sd3irad8mv7zlg4242i8pmg5xyhbyq95kymwibaid"))))
+ (version "2.5.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gdamore/tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pvs0gigqxpifc7y7cx82cg95pgqmy8qzxynja3zidplrx2075j3"))))
(arguments
- `(#:import-path "github.com/gdamore/tcell/v2"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))))))))
+ (list #:import-path "github.com/gdamore/tcell/v2"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda _
+ ;; Make sure .gz files are writable so that the
+ ;; 'reset-gzip-timestamps' phase can do its work.
+ (for-each make-file-writable
+ (find-files #$output "\\.gz$")))))))
(propagated-inputs
(modify-inputs (package-inputs go-github-com-gdamore-tcell)
(prepend go-golang-org-x-term go-golang-org-x-sys)))))