summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-01-30 20:08:04 +0000
committerLudovic Courtès <ludo@gnu.org>2024-02-18 16:04:21 +0100
commit13e7d4d399182a1146beae802b9608f0b7a43e6c (patch)
treeb5ceec5298ab2346a787d876e28c5e3d765a1939
parentb23fd4fb3e345d7c17b0e668bf790d310426f02b (diff)
gnu: Add go-github-com-cli-safeexec.
* gnu/packages/golang.scm (go-github-com-cli-safeexec): New variable. Change-Id: Ibc183f5185de16b4d6528697cbc85183a3282733 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 527b63d160..0b8b656a8e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4757,6 +4758,28 @@ source files. A neutral variety of English is used by default, but a US or UK
locale can be selected.")
(license license:expat)))
+(define-public go-github-com-cli-safeexec
+ (package
+ (name "go-github-com-cli-safeexec")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cli/safeexec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0j6hspjx9kyxn98nbisawx6wvbi1d6rpzr6p2rzhllm673wibwr3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/cli/safeexec"))
+ (home-page "https://github.com/cli/safeexec")
+ (synopsis "Safe implementation of Go's exec.Command")
+ (description "This package provides a Go module that provides a stabler
+alternative to @@code{exec.LookPath()}.")
+ (license license:bsd-2)))
+
(define-public go-github-com-client9-misspell
(package
(inherit misspell)