summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhackeryarn <artemchernyak@gmail.com>2021-10-04 21:08:46 -0500
committerLudovic Courtès <ludo@gnu.org>2021-10-13 11:48:04 +0200
commit1628e5d51b9cb1d526b8a55c670f65946fd7c970 (patch)
treecef4813991bd5535d9da8c3e7ff55450c05afe90
parent859d5a1f1d8486b509a80769a33dd546a6d4c1b2 (diff)
gnu: Add go-golang-org-x-mod.
* gnu/packages/golang.scm (go-golang-org-x-mod): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a96f743f68..e39c67b942 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2669,6 +2669,41 @@ time.")
(home-page "https://godoc.org/golang.org/x/xerrors")
(license license:bsd-3))))
+(define-public go-golang-org-x-mod
+ (let ((commit "0f08993efd8a8ec67e75bcccf86b0e1569b0ab0a")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-mod")
+ (version (git-version "0.5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/x/mod")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pl0jc5jvg7hxj4z66zg6kglnq5g7li09f3k9klwvyr4jx5dw88k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/mod/"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (home-page "https://golang.org/x/mod")
+ (synopsis "Tools to work directly with Go module mechanics")
+ (description
+ "This repository holds packages for writing tools that work directly
+with Go module mechanics. That is, it is for direct manipulation of Go modules
+themselves.
+
+The specific case of loading packages should still be done by invoking the
+@command{go} command, which remains the single point of truth for package
+loading algorithms.")
+ (license license:bsd-3))))
+
(define-public go-github-com-burntsushi-toml
(package
(name "go-github-com-burntsushi-toml")