summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-30 11:52:44 +0100
committerMarius Bakke <marius@gnu.org>2022-12-02 00:21:25 +0100
commit168afe297630c6b2dd9f1fa029541cced9117ca1 (patch)
tree664c2a7080fbe1814c875d8a57a9a683b709172b
parent84c577d7a7046c2d675d674c301ae1f4684a80bd (diff)
gnu: svt-av1: Update to 1.3.0.
* gnu/packages/video.scm (svt-av1): Update to 1.3.0. [supported-systems]: Remove. [description]: Update.
-rw-r--r--gnu/packages/video.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 297252d1ae..6e0a1e313c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5120,7 +5120,7 @@ transcode or reformat the videos in any way, producing perfect backups.")
(define-public svt-av1
(package
(name "svt-av1")
- (version "0.9.1")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -5129,10 +5129,8 @@ transcode or reformat the videos in any way, producing perfect backups.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "02fchq2vlxcxzbrss72xl9vrxzysdy39d5i159bmg3qa45ngd2iw"))))
+ (base32 "0blnla32yz665bx0xyx8lrjs2wqd2xhpbqwwpz72mq7zf341j8vv"))))
(build-system cmake-build-system)
- ;; SVT-AV1 only supports 64-bit Intel-compatible CPUs.
- (supported-systems '("x86_64-linux"))
(arguments
;; The test suite tries to download test data and git clone a 3rd-party
;; fork of libaom. Skip it.
@@ -5150,7 +5148,8 @@ transcode or reformat the videos in any way, producing perfect backups.")
(synopsis "AV1 video codec")
(description "SVT-AV1 is an AV1 codec implementation. The encoder is a
work-in-progress, aiming to support video-on-demand and live streaming
-applications. It only supports Intel-compatible CPUs (x86).")
+applications with high performance requirements. It mainly targets
+Intel-compatible CPUs (x86), but has limited support for other architectures.")
(home-page "https://gitlab.com/AOMediaCodec/SVT-AV1")
(license license:bsd-2)))