summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-22 21:05:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:12 +0200
commit1b47af9f108fc391284ab72d1d3e4dfec5fd70e7 (patch)
treedbed7adda6561fe54cd565d7bdd3d0c947d1daad
parent5e20babe0228c0a6fefee39b17d2685768e8607c (diff)
gnu: rust-skeptic-0.13: Update to 0.13.7.
* gnu/packages/crates-io.scm (rust-skeptic-0.13): Update to 0.13.7. [arguments]: Don't skip the build. Add cargo-test-flags. [cargo-inputs]: Add rust-tempfile-3. Replace rust-bytecount-0.4 with 0.6, rust-cargo-metadata-0.6 with 0.14, rust-glob-0.2 with 0.3, rust-pulldown-cmark-0.2 with 0.9. Remove rust-tempdir-0.3, rust-serde-json-1. [cargo-development-inputs]: Add rust-unindent-0.1. Change-Id: I0c7a3931114efc241a4a044cbe824d9c0ceb3a08
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fcfbe2ded6..be91f8ab65 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -61987,28 +61987,29 @@ designed for @code{immutable.rs}.")
(define-public rust-skeptic-0.13
(package
(name "rust-skeptic")
- (version "0.13.4")
+ (version "0.13.7")
(source
(origin
(method url-fetch)
(uri (crate-uri "skeptic" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0rai61hbs65nbvbhqlk1nap5hlav5qx3zmjjjzh9rhgxagc8xyyn"))))
+ (base32 "1a205720pnss0alxvbx0fcn3883cg3fbz5y1047hmjbnaq0kplhn"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
+ `(#:cargo-test-flags
+ '("--release" "--"
+ ;; Not all files included.
+ "--skip=tests::test_markdown_files_of_directory")
#:cargo-inputs
(("rust-error-chain" ,rust-error-chain-0.12)
- ("rust-pulldown-cmark" ,rust-pulldown-cmark-0.2)
- ("rust-glob" ,rust-glob-0.2)
- ("rust-tempdir" ,rust-tempdir-0.3)
- ("rust-bytecount" ,rust-bytecount-0.4)
- ("rust-cargo-metadata" ,rust-cargo-metadata-0.6)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-walkdir" ,rust-walkdir-2))))
+ ("rust-bytecount" ,rust-bytecount-0.6)
+ ("rust-cargo-metadata" ,rust-cargo-metadata-0.14)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-pulldown-cmark" ,rust-pulldown-cmark-0.9)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-walkdir" ,rust-walkdir-2))
+ #:cargo-development-inputs (("rust-unindent" ,rust-unindent-0.1))))
(home-page "https://github.com/budziq/rust-skeptic")
(synopsis "Test your Rust markdown documentation via Cargo")
(description