summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-26 21:49:55 +0200
committerLudovic Courtès <ludo@gnu.org>2023-03-30 12:44:20 +0200
commit1c179980fa32ef436c5d49d275510444573cf1ea (patch)
treeb722673577c25bb181d69590b2a43702e60ce3a2
parentfda221c469f8d31cdc22bc5053e6b19017764c62 (diff)
gnu: linux-pam: Switch to gexps.
* gnu/packages/linux.scm (linux-pam)[arguments]: Switch to gexps.
-rw-r--r--gnu/packages/linux.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 50d5249832..4bc547e832 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1804,28 +1804,29 @@ which need to be installed separately.")
;; ("cracklib" ,cracklib)
))
(arguments
- `(;; Most users, such as `shadow', expect the headers to be under
- ;; `security'.
- #:configure-flags (list (string-append "--includedir="
- (assoc-ref %outputs "out")
- "/include/security")
- ;; explicit libdir for pkgconfig files
- ;; drop with 1.5.3, which fixes
- ;; https://github.com/linux-pam/linux-pam/issues/466
- (string-append "--libdir="
- (assoc-ref %outputs "out")
- "/lib")
-
- ;; XXX: <rpc/rpc.h> is missing from glibc when
- ;; cross-compiling, so we have to disable NIS
- ;; support altogether.
- ,@(if (%current-target-system)
- '("--disable-nis")
- '()))
-
- ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
- ;; isn't available.
- #:tests? #f))
+ (list
+ ;; Most users, such as `shadow', expect the headers to be under
+ ;; `security'.
+ #:configure-flags #~(list (string-append "--includedir="
+ (assoc-ref %outputs "out")
+ "/include/security")
+ ;; explicit libdir for pkgconfig files
+ ;; drop with 1.5.3, which fixes
+ ;; https://github.com/linux-pam/linux-pam/issues/466
+ (string-append "--libdir="
+ (assoc-ref %outputs "out")
+ "/lib")
+
+ ;; XXX: <rpc/rpc.h> is missing from glibc when
+ ;; cross-compiling, so we have to disable NIS
+ ;; support altogether.
+ #$@(if (%current-target-system)
+ #~("--disable-nis")
+ #~()))
+
+ ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
+ ;; isn't available.
+ #:tests? #f))
(home-page "http://www.linux-pam.org/")
(synopsis "Pluggable authentication modules for Linux")
(description