summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-03-28 11:04:42 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-03-28 13:08:34 +0100
commit1da36e4db925addecbd49a504752d9efb9b6eb7e (patch)
tree10dd14c9c02ab1e1326a0474ed4b3a574e8d223e
parentb8f6b013b9c764561dd552df23a8a0abc3eba175 (diff)
gnu: Add python-pytest-testmon.
* gnu/packages/python-check.scm (python-pytest-testmon): New variable. Change-Id: Ia2e6034781898c04bd766145e0352060a975d479 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 51a38bbcbe..69663f67e9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1093,6 +1094,28 @@ of the project to ensure it renders properly.")
simpler.")
(license license:expat)))
+(define-public python-pytest-testmon
+ (package
+ (name "python-pytest-testmon")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarpas/pytest-testmon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01qhbkb3n8c5c4id94w6b06q9wb7b6a33mqwyrkdfzk5pzv1gcyd"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (native-inputs (list python-coverage python-pytest))
+ (home-page "https://github.com/tarpas/pytest-testmon")
+ (synopsis "Selects tests affected by changed files and methods")
+ (description
+ "This plug-in auto-selects and reruns tests impacted by recent changes.")
+ (license license:expat)))
+
(define-public python-pytest-trio
(package
(name "python-pytest-trio")