summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-14 14:44:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-14 14:45:47 +0200
commit20185e4fe7e9ff8f03aff289e186daf4789c5f2f (patch)
treee7e6f39e91c0685e25e5d637c865bf10e1074a30
parentdf8ab77450b24c02ff075acda79826e3099f78e7 (diff)
gnu: Add simgear.
* gnu/packages/games.scm (simgear): New variable.
-rw-r--r--gnu/packages/games.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5c1a8f6792..8ca33f4d95 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6828,3 +6828,39 @@ levels to unlock.")
(license (list license:gpl2+
license:silofl1.1
license:cc-by-sa3.0)))))
+
+(define simgear
+ (package
+ (name "simgear")
+ (version "2018.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/flightgear/release-"
+ (version-major+minor version) "/"
+ "simgear-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1941ay8rngz4vwsx37bbpxr48hpcvcbj3xw1hy264lq4qnl99c68"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; Skip tests that require internet access.
+ (invoke "ctest" "-E" "(http|dns)"))))))
+ (inputs
+ `(("boost" ,boost-for-mysql) ; fails with 1.69
+ ("curl" ,curl)
+ ("expat" ,expat)
+ ("mesa" ,mesa)
+ ("openal" ,openal)
+ ("openscenegraph" ,openscenegraph-3.4)
+ ("zlib" ,zlib)))
+ (home-page "https://home.flightgear.org/")
+ (synopsis "Libraries for 3D simulations and games")
+ (description "SimGear is a set of libraries designed to be used as
+building blocks for quickly assembling 3D simulations, games, and
+visualization applications. SimGear is developed by the FlightGear project
+and also provides the base for the FlightGear Flight Simulator.")
+ (license license:lgpl2.0+)))