summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commit21363801ae8d9c5812e7ca352de4f8954c690af9 (patch)
tree593014288803e30e9d7ef344402f47773e595032
parentaaa0a4c6366755fb0cfb38c4f6fbe57cb8b94772 (diff)
gnu: bcachefs-tools: Remove obsolete phase.
* gnu/packages/file-systems.scm (bcachefs-tools)[arguments]: Remove obsolete phase to 'patch-shell-wrappers that no longer exist.
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index f10d56ec3f..b98a838f43 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -619,17 +619,7 @@ from a mounted file system.")
"not test_fsck and "
"not test_list and "
"not test_list_inodes and "
- "not test_list_dirent")))))
- (add-after 'install 'patch-shell-wrappers
- ;; These are overcomplicated wrappers that invoke readlink(1)
- ;; to exec the appropriate bcachefs(8) subcommand. We can
- ;; simply patch in the latter file name directly, and do.
- (lambda _
- (let ((sbin/ (string-append #$output "/sbin/")))
- (substitute* (find-files sbin/ (lambda (file stat)
- (not (elf-file? file))))
- (("SDIR=.*") "")
- (("\\$\\{SDIR.*}/") sbin/))))))))
+ "not test_list_dirent"))))))))
(native-inputs
(cons* pkg-config
;; For generating documentation with rst2man.