summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 14:32:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 14:35:18 +0100
commit22482834c5412df9816adefecbf8915221999edb (patch)
treebdf3d380379f9c67b22b3298eec748fb5a36b81c
parent3036a2ed434efa1c34f9533293dc5e37de3102b3 (diff)
gnu: wally-cli: Fix build.
Reported by Christopher Baines <mail@cbaines.net> in <https://lists.gnu.org/archive/html/guix-devel/2024-06/msg00112.html>. * gnu/packages/flashing-tools.scm (wally-cli) [arguments]: <#:phases>: Add 'fix-module-name phase. Change-Id: I106c0412a9d05f65d25d3e3d620e1152cc5c8a2c
-rw-r--r--gnu/packages/flashing-tools.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 776f5012a2..c054e46bd3 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -654,7 +654,18 @@ It can be used to upload images to I.MX SoC's using at least their boot ROM.")
(arguments
(list
#:install-source? #f
- #:import-path "github.com/zsa/wally-cli"))
+ #:import-path "github.com/zsa/wally-cli"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Upstream Golang module name was changed from
+ ;; <gopkg.in/cheggaaa/pb.v1> to <github.com/cheggaaa/pb>, adjust
+ ;; references to it accordingly. Remove it in the new release of
+ ;; the package.
+ (add-after 'unpack 'fix-module-name
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* "main.go"
+ (("gopkg.in/cheggaaa/pb.v1") "github.com/cheggaaa/pb"))))))))
(native-inputs
(list go-github-com-briandowns-spinner
go-github-com-google-gousb