summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:25 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:32:05 -0500
commit22789276b53d6156ddb722c68615c22a54a35d27 (patch)
tree3d1450c0b7e81697234c06223656cae480b890d4
parent29b0fc4cdaf8d215b83dddbb98a82428c4f92150 (diff)
gnu: Add go-github-com-emersion-go-maildir.
* gnu/packages/golang.scm (go-github-com-emersion-go-maildir): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5c0b79b28c..1a4d0cc681 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6744,6 +6744,29 @@ defined by RFC 5321.")
(description "This package provides an IDLE extension for go-imap.")
(license license:expat))))
+(define-public go-github-com-emersion-go-maildir
+ (package
+ (name "go-github-com-emersion-go-maildir")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-maildir")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rs9kbacjpcza25pmdkbm7sdm7r6gq4g44nihi9asyrvspx96zf2"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/emersion/go-maildir"))
+ (home-page "https://github.com/emersion/go-maildir")
+ (synopsis "Maildir interface for Go")
+ (description
+ "This package provides an interface to mailboxes in the Maildir
+format.")
+ (license license:expat)))
+
(define-public go-github-com-fatih-color
(package
(name "go-github-com-fatih-color")