summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-06-25 22:28:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:01 +0200
commit22a1e419c1c7ec2d491b74ccc9a8bf828e3cce8e (patch)
treed8b63484c9a14c56b545e138ee40ae229d9f7092
parentca7b387645dad3c94ce9af851ef067aa0dad5992 (diff)
gnu: stuff: Update to 2.0.1.
* gnu/packages/astronomy.scm (stuff): Update to 2.0.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf, automake, libtool, and pkg-config. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5d6707dab7..16bb27c87a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1125,15 +1125,21 @@ objects.")
(define-public stuff
(package
(name "stuff")
- (version "1.26.0")
+ (version "2.0.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/stuff/"
- "stuff-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/stuff")
+ ;; XXX: No version tag available in GitHub.
+ ;; See: https://github.com/astromatic/stuff/issues/6
+ (commit "9008dc022ef53331092da248cf0a794abd6783bf")))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1syibi3b86z9pikhicvkkmgxm916j732fdiw0agw0lq6z13fdcjm"))))
+ (base32 "004sry5lqqm7s9x4l3agysp3n63y3ga35x1rwwda4m6dc6zvla6b"))))
(build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
(home-page "https://www.astromatic.net/software/stuff")
(synopsis "Astronomical catalogue simulation")
(description