summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-08 15:41:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-08 15:52:15 +0100
commit2387d0cce4eb54dd5b8846eceef463e7393d1f32 (patch)
tree0dd8c26c334341c8e42f654e7b9467bf5189a191
parentb7a02801e9f3acf607b2800c129fc01cd553e59e (diff)
gnu: emacs-cmake-font-lock: Update to 0.1.13.
* gnu/packages/emacs-xyz.scm (emacs-cmake-font-lock): Update to 0.1.13.
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 21 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8dcf2e6771..686c5c58b4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27653,31 +27653,28 @@ indentation and a command to plot the file.")
(license license:gpl3+)))
(define-public emacs-cmake-font-lock
- ;; Upstream does not tag commits. The commit hash below matches version
- ;; bump.
- (let ((commit "0d6111b36a66013aa9b452e664c93308df3b07e1"))
- (package
- (name "emacs-cmake-font-lock")
- (version "0.1.12")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Lindydancer/cmake-font-lock")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12ga8ri7v9r5y46pghk80ww27i7nhbrg0r3s2ina42drlkkliqj4"))))
- (build-system emacs-build-system)
- (native-inputs
- (list emacs-faceup))
- (arguments
- (list #:include #~(cons "^admin\\/" %default-include)))
- (home-page "https://github.com/Lindydancer/cmake-font-lock")
- (synopsis "Advanced type-aware syntax-highlighting for CMake")
- (description "This package highlights function arguments in CMake
+ (package
+ (name "emacs-cmake-font-lock")
+ (version "0.1.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lindydancer/cmake-font-lock")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18kvs2yq6plw6lngs97wxl7qah5iwrnhq2q68aac9z8fpwq0vhz8"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:include #~(cons "^admin\\/" %default-include)))
+ (native-inputs
+ (list emacs-faceup))
+ (home-page "https://github.com/Lindydancer/cmake-font-lock")
+ (synopsis "Advanced type-aware syntax-highlighting for CMake")
+ (description "This package highlights function arguments in CMake
according to their use.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-detached
(package