summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-09-17 21:12:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 13:48:32 +0300
commit23bf7cba07e091831fec9c17898b3248bda95c33 (patch)
treec0b6bf7ea43bc2a8d07b0a3712408f90052f4e13
parentbe7d68f08bf2b52d43d44ee391bafd319cae8c41 (diff)
gnu: Add wcslib-7.12.
* gnu/packages/astronomy.scm (wcslib-7.12): New variable.
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc61baa92b..4afde96a8c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2023 Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -738,6 +739,21 @@ coordinate systems in a @dfn{FITS} (Flexible Image Transport System) image
header.")
(license license:lgpl3+)))
+;;; The version is required for julia-wcs-jll and julia-wcs. They do not
+;;; support version higher than 7.x.
+(define-public wcslib-7.12
+ (package
+ (inherit wcslib)
+ (version "7.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.atnf.csiro.au/people/mcalabre/WCS/"
+ "wcslib-" version ".tar.bz2"))
+ (sha256
+ (base32 "1m3bx6gh5w3c7vvsqcki0x20mg8lilg13m0i8nh7za89w58dxy4w"))))
+ (properties '((hidden? . #t)))))
+
(define-public weightwatcher
(package
(name "weightwatcher")