summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-11 01:07:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:22 -0400
commit23d2319f9aab48fbb31d63e04197839600d01967 (patch)
treee1692be8ab6b5c44c5aa4b32a0f1945b23430017
parente6f46eabbd1694d0c947af9f53778ca66561c47c (diff)
gnu: python-prompt-toolkit: Update to 3.0.29.
* gnu/packages/python-xyz.scm (python-prompt-toolkit): Update to 3.0.29. [phases]{post-install-check}: Move to... {check}: ... this phase override instead, and streamline.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6bcb17dfad..5bf168df1f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17228,25 +17228,24 @@ collections of data.")
(define-public python-prompt-toolkit
(package
(name "python-prompt-toolkit")
- (version "3.0.18")
+ (version "3.0.29")
(source
(origin
(method url-fetch)
(uri (pypi-uri "prompt_toolkit" version))
(sha256
- (base32 "1g1kq1aimhm23k2dmlmnznfzc83l6ly65g0h32hqz8injcdz3d71"))))
+ (base32 "19vf5cahp3imdpwhgvk55g3dvqmc6ga175r4vkq79kffx1h0yr5x"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'check)
- (add-after 'install 'post-install-check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; HOME is needed for the test
- ;; "test_pathcompleter_can_expanduser".
- (setenv "HOME" "/tmp")
- (add-installed-pythonpath inputs outputs)
- (invoke "py.test"))))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; HOME is needed for the test
+ ;; "test_pathcompleter_can_expanduser".
+ (setenv "HOME" "/tmp")
+ (invoke "pytest" "-vv")))))))
(propagated-inputs
(list python-wcwidth))
(native-inputs