summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 22:31:48 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 22:41:23 +0200
commit2619fa3d77961326cfbf7ddc87d519df30b49559 (patch)
tree28a1b643fd1350d45ea871e2b1059619f99274e7
parent30fff95ee62f72e14cd4ac6257411034589482f7 (diff)
gnu: Remove wayland-protocols-next.
* gnu/packages/freedesktop.scm (wayland-protocols-next): Remove variable. * gnu/packages/gnome.scm (mutter)[native-inputs]: Change from WAYLAND-PROTOCOLS-NEXT to WAYLAND-PROTOCOLS. * gnu/packages/kde-plasma.scm (kwayland-server)[inputs]: Likewise. * gnu/packages/wm.scm (swaylock)[native-inputs]: Likewise.
-rw-r--r--gnu/packages/freedesktop.scm14
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/kde-plasma.scm2
-rw-r--r--gnu/packages/wm.scm2
4 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 2551c88761..b8387878d1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1122,20 +1122,6 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
-(define-public wayland-protocols-next
- (package
- (inherit wayland-protocols)
- (name "wayland-protocols")
- (version "1.26")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://wayland.freedesktop.org/releases/"
- "wayland-protocols-" version ".tar.xz"))
- (sha256
- (base32
- "04vgllmpmrv14x3x64ns01vgwx4hriljayjkz9idgbv83i63hly5"))))))
-
(define-public waylandpp
(package
(name "waylandpp")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cb255fc488..0fa67b405e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7791,7 +7791,7 @@ to display dialog boxes from the commandline and shell scripts.")
autoconf
automake
libtool
- wayland-protocols-next
+ wayland-protocols
;; For tests.
;; Warnings are configured to be fatal during the tests; add an icon
;; theme to please libxcursor.
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 634a44eecf..265799cd94 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -358,7 +358,7 @@ with a ksysguardd daemon, which may also run on a remote system.")
qtwayland
kwayland
wayland
- wayland-protocols-next))
+ wayland-protocols))
(arguments
'(#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 87bed6e8b9..f30285a5fd 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1668,7 +1668,7 @@ modules for building a Wayland compositor.")
(inputs (list cairo gdk-pixbuf libxkbcommon
;("linux-pam" ,linux-pam) ; FIXME: Doesn't work.
wayland))
- (native-inputs (list pango pkg-config scdoc wayland-protocols-next))
+ (native-inputs (list pango pkg-config scdoc wayland-protocols))
(home-page "https://github.com/swaywm/sway")
(synopsis "Screen locking utility for Wayland compositors")
(description "Swaylock is a screen locking utility for Wayland compositors.")