summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2023-08-21 11:47:57 +0100
committerHilton Chain <hako@ultrarare.space>2023-08-27 11:39:53 +0800
commit262efbf9b1bc3d589501d7291d5373a57c04c81b (patch)
tree8d707d1748e66fd2c7fdb4541cafc5dc0aabd11b
parent5476f79e41c843a7ee43f6fcf64039f527b9f21e (diff)
gnu: emacs-hide-mode-line: Update to 1.0.3.
* gnu/packages/emacs-xyz.scm (emacs-hide-mode-line): Update to 1.0.3. Signed-off-by: Hilton Chain <hako@ultrarare.space>
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dcc9852651..9d2bb63674 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34192,25 +34192,28 @@ shift-reduce parser function.")
(license license:gpl3+)))
(define-public emacs-hide-mode-line
- (package
- (name "emacs-hide-mode-line")
- (version "1.0.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hlissner/emacs-hide-mode-line")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0dfzjgxfkcw4wisbyldsm1km18pfp9j8xgadn6qnsz11l55bpgyp"))))
- (build-system emacs-build-system)
- (synopsis "Emacs plugin that hides the mode-line")
- (description "A minor mode that hides the mode-line in your current
-buffer. It can be used to toggle an alternative mode-line, toggle its visibility,
-or simply disable the mode-line in buffers where it is not very useful.")
- (home-page "https://github.com/hlissner/emacs-hide-mode-line")
- (license license:expat)))
+ ;; XXX: Commit below refers to the un-tagged latest release.
+ (let ((commit "bc5d293576c5e08c29e694078b96a5ed85631942"))
+ (package
+ (name "emacs-hide-mode-line")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hlissner/emacs-hide-mode-line")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12mfhg0r3gvy59ijy44vsircn251nmisp04k9vvgd2yhykpsr1j6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/hlissner/emacs-hide-mode-line")
+ (synopsis "Emacs plugin that hides the mode-line")
+ (description
+ "A minor mode that hides the mode-line in your current buffer. It can be
+used to toggle an alternative mode-line, toggle its visibility, or simply
+disable the mode-line in buffers where it is not very useful.")
+ (license license:expat))))
(define-public emacs-helm-cider
(package