summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-06 14:10:18 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:55 +0200
commit26488f63b8e4845cc9ed6e91b0643936b5eaa509 (patch)
treecb1c599f2daf2c64914c700a408dc0756335d6de
parent07f2e4993b5b80008273de0bb756659321e74183 (diff)
gnu: pigx-rnaseq: Remove dependency on pandoc-citeproc.
* gnu/packages/patches/pigx-rnaseq-no-citeproc.patch: Add patch. * gnu/local.mk: Register it. * gnu/packages/bioinformatics.scm (pigx-rnaseq)[source]: Use it. [native-inputs]: Add automake/autoconf.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm10
-rw-r--r--gnu/packages/patches/pigx-rnaseq-no-citeproc.patch33
3 files changed, 42 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 71f1a25f83..110980bef0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1601,6 +1601,7 @@ dist_patch_DATA = \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pigx-bsseq-no-citeproc.patch \
%D%/packages/patches/pigx-chipseq-no-citeproc.patch \
+ %D%/packages/patches/pigx-rnaseq-no-citeproc.patch \
%D%/packages/patches/pigx-sars-cov2-ww-no-citeproc.patch \
%D%/packages/patches/pinball-system-ltdl.patch \
%D%/packages/patches/pingus-boost-headers.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 150bbc361f..f5de16877e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10489,7 +10489,8 @@ once. This package provides tools to perform Drop-seq analyses.")
"/pigx_rnaseq-" version ".tar.gz"))
(sha256
(base32
- "1ja3bda1appxrzbfy7wp7khy30mm7lic8xbq3gkbpc5bld3as9cm"))))
+ "1ja3bda1appxrzbfy7wp7khy30mm7lic8xbq3gkbpc5bld3as9cm"))
+ (patches (search-patches "pigx-rnaseq-no-citeproc.patch"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; not supported
@@ -10502,6 +10503,9 @@ once. This package provides tools to perform Drop-seq analyses.")
(substitute* "Makefile.in"
(("^ tests/test_multiqc/test.sh") "")
(("^ test.sh") ""))))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif")))
(add-before 'check 'set-timezone
;; The readr package is picky about timezones.
(lambda* (#:key inputs #:allow-other-keys)
@@ -10545,7 +10549,9 @@ once. This package provides tools to perform Drop-seq analyses.")
("python-deeptools" ,python-deeptools)
("python-pyyaml" ,python-pyyaml)))
(native-inputs
- `(("tzdata" ,tzdata)))
+ `(("tzdata" ,tzdata)
+ ("automake" ,automake)
+ ("autoconf" ,autoconf)))
(home-page "https://bioinformatics.mdc-berlin.de/pigx/")
(synopsis "Analysis pipeline for RNA sequencing experiments")
(description "PiGX RNAseq is an analysis pipeline for preprocessing and
diff --git a/gnu/packages/patches/pigx-rnaseq-no-citeproc.patch b/gnu/packages/patches/pigx-rnaseq-no-citeproc.patch
new file mode 100644
index 0000000000..366ae3890a
--- /dev/null
+++ b/gnu/packages/patches/pigx-rnaseq-no-citeproc.patch
@@ -0,0 +1,33 @@
+diff -Naur pigx_rnaseq-0.0.19/configure.ac pigx_rnaseq-0.0.19.patched/configure.ac
+--- pigx_rnaseq-0.0.19/configure.ac 2021-07-23 14:01:00.304391428 +0200
++++ pigx_rnaseq-0.0.19.patched/configure.ac 2021-10-06 13:51:29.512960106 +0200
+@@ -38,7 +38,6 @@
+ find_or_override_prog([GNUBASH], [bash])
+ find_or_override_prog([SNAKEMAKE], [snakemake])
+ find_or_override_prog([PANDOC], [pandoc])
+-find_or_override_prog([PANDOC_CITEPROC], [pandoc-citeproc])
+ find_or_override_prog([STAR], [STAR])
+ find_or_override_prog([HISAT2], [hisat2])
+ find_or_override_prog([HISAT2_BUILD], [hisat2-build])
+diff -Naur pigx_rnaseq-0.0.19/Makefile.in pigx_rnaseq-0.0.19.patched/Makefile.in
+--- pigx_rnaseq-0.0.19/Makefile.in 2021-08-13 13:40:10.402922844 +0200
++++ pigx_rnaseq-0.0.19.patched/Makefile.in 2021-10-06 13:51:04.052247524 +0200
+@@ -410,7 +410,6 @@
+ PACKAGE_URL = @PACKAGE_URL@
+ PACKAGE_VERSION = @PACKAGE_VERSION@
+ PANDOC = @PANDOC@
+-PANDOC_CITEPROC = @PANDOC_CITEPROC@
+ PATH_SEPARATOR = @PATH_SEPARATOR@
+ PYTHON = @PYTHON@
+ PYTHONPATH = @PYTHONPATH@
+diff -Naur pigx_rnaseq-0.0.19/pigx-common/common/pigx-runner.in pigx_rnaseq-0.0.19.patched/pigx-common/common/pigx-runner.in
+--- pigx_rnaseq-0.0.19/pigx-common/common/pigx-runner.in 2021-08-13 13:27:50.494352532 +0200
++++ pigx_rnaseq-0.0.19.patched/pigx-common/common/pigx-runner.in 2021-10-06 13:51:38.798220108 +0200
+@@ -379,7 +379,6 @@
+ if path.exists(bin): shutil.rmtree(bin)
+ os.makedirs(bin, exist_ok=True)
+ os.symlink('@PANDOC@', path.join(bin, "pandoc"))
+- os.symlink('@PANDOC_CITEPROC@', path.join(bin, "pandoc-citeproc"))
+ os.symlink('@RSCRIPT@', path.join(bin, "Rscript"))
+ os.environ['PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
+ os.environ['PIGX_PATH'] = path.abspath(bin) + ":" + os.environ['PATH']