summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 00:12:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:32 -0400
commit26d92095d6870c0d10ef3a0f16256d7979a8dba5 (patch)
tree5b6feae435c80c8df9016791d87edc431d7f4b18
parentf761974b123d1129849dd2be11dab0893b4d5766 (diff)
gnu: Add python-jaraco-context.
* gnu/packages/python-xyz.scm (python-jaraco-context): New variable.
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a9d77fe84c..f586728ce9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8616,6 +8616,35 @@ class constructs.")
procedures.")
(license license:expat))))
+(define-public python-jaraco-context
+ (package/inherit python-jaraco-context-bootstrap
+ (name "python-jaraco-context")
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments python-jaraco-context-bootstrap)
+ ((#:tests? _ #f)
+ #t)
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Do not test the myproject.toml build as it tries to pull
+ ;; dependencies from the Internet.
+ (invoke "pytest" "-vv" "-k" "not project"))))))))
+ (native-inputs
+ (modify-inputs
+ (package-native-inputs python-jaraco-context-bootstrap)
+ (append python-pytest
+ python-pytest-black
+ python-pytest-checkdocs
+ python-pytest-cov
+ python-pytest-enabler-bootstrap ;OK since not propagated
+ python-pytest-flake8
+ python-pytest-mypy)))
+ (properties (alist-delete 'hidden? (package-properties
+ python-jaraco-context-bootstrap)))))
+
;;; Variant used to break a cycle with python-pytest-enabler.
(define-public python-jaraco-functools-bootstrap
(hidden-package