summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-08 16:58:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-08 16:59:32 +0300
commit27e33695b38ecfe28c9d6b2d35e7e87826611a76 (patch)
tree4d70c25a5c4e0fe53db0678c0d93c8f9970b1aa6
parentba8ddb348045f81f061a1c7f51c0f7c2b0024e71 (diff)
gnu: supertuxkart: Update to 1.3.
* gnu/packages/games.scm (supertuxkart): Update to 1.3. [source]: Download from github. Update snippet to remove different bundled libraries. [arguments]: Adjust configure-flags for new version. [inputs]: Add sqlite.
-rw-r--r--gnu/packages/games.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 58d28d7da1..3b8946e42f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3951,15 +3951,16 @@ This game is based on the GPL version of the famous game TuxRacer.")
(define-public supertuxkart
(package
(name "supertuxkart")
- (version "1.2")
+ (version "1.3")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/supertuxkart/SuperTuxKart/"
+ (uri (string-append "https://github.com/supertuxkart/stk-code/"
+ "releases/download/"
version "/SuperTuxKart-" version "-src.tar.xz"))
(sha256
(base32
- "0dvx56hmy6wdhl7m9dw8zc1n3jqfp05gnxl6zs1rbfdyzl5dybh5"))
+ "1z9z13zarv28h4jrmjna5hr6m9266pm7c2kgiwhqls01k06ypazf"))
(modules '((guix build utils)))
(snippet
;; Delete bundled library sources
@@ -3969,17 +3970,18 @@ This game is based on the GPL version of the famous game TuxRacer.")
;; here: http://forum.freegamedev.net/viewtopic.php?f=17&t=3906
;; FIXME: try to unbundle angelscript, libmcpp and libraqm
(for-each delete-file-recursively
- '("lib/glew"
- "lib/wiiuse"
- "lib/enet"))
+ '("lib/dnsc"
+ "lib/enet"
+ "lib/mojoal"
+ "lib/wiiuse"))
#t))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no check target
#:configure-flags
(list "-DUSE_WIIUSE=0"
- "-DUSE_SYSTEM_GLEW=TRUE"
"-DUSE_SYSTEM_ENET=TRUE"
+ "-DUSE_CRYPTO_OPENSSL=TRUE"
;; In order to use the system ENet library, IPv6 support (added in
;; SuperTuxKart version 1.1) must be disabled.
"-DUSE_IPV6=FALSE"
@@ -3997,6 +3999,7 @@ This game is based on the GPL version of the famous game TuxRacer.")
("mesa" ,mesa)
("openal" ,openal)
("sdl2" ,sdl2)
+ ("sqlite" ,sqlite)
("zlib" ,zlib)
;; The following input is needed to build the bundled and modified
;; version of irrlicht.