summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-03-20 22:13:40 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-24 09:31:25 +0100
commit29be505fceb63d53d1f47312c913e682d19a03d7 (patch)
tree135d2a7b53b4d66d0f73ac2d7c5b5dec6296ec49
parentced76608d68a5832b94dcf7aa18df1115a4c06c0 (diff)
gnu: emacs-buttercup: Fix build with native compilation.
* gnu/packages/emacs-xyz.scm (emacs-buttercup)[phases]{fix-spy-on-test}: New phase. The spy-on test fails with native compilation, which was fixed in v1.30 but with a variable name for newer versions than stable Emacs. Here we add the same fix but using the current variable name. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e4069cb7c..00c4cf5913 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27190,6 +27190,16 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
#:test-command #~(list "make" "test")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-spy-on-test
+ (lambda _
+ (substitute* "buttercup.el"
+ ;; The spy-on test fails with native compilation, which was
+ ;; fixed in v1.30 but with a variable name for Emacs newer
+ ;; than 28.2. Add in the same fix with the current variable
+ ;; name. Upstream bug and fix:
+ ;; <https://github.com/jorgenschaefer/emacs-buttercup/issues/236>
+ (("\\(native-comp-enable-subr-trampolines nil\\)" all)
+ (string-append all " (comp-enable-subr-trampolines nil)")))))
(add-after 'install 'install-bin
(lambda _
(install-file "bin/buttercup"