summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-08-10 11:36:01 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-11 00:50:47 +0200
commit2a4047e5401a1b41c15803725f368483ab4377fa (patch)
tree583c1e203a8750a790146c02ee0dccc21d103c29
parent229faac39b07250ceabd77d8f728d2e38a6c8b7d (diff)
gnu: libflame: Remove input labels and use gexps.
* gnu/packages/maths.scm (libflame)[arguments]: Use gexps and remove trailing #t in phases. [inputs, native-inputs]: Remove labels.
-rw-r--r--gnu/packages/maths.scm95
1 files changed, 46 insertions, 49 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 96f06f2652..420f1894f3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2615,55 +2615,52 @@ fixed point (16.16) format.")
"1n6lf0wvpp77lxqlr721h2jbfbzigphdp19wq8ajiccilcksh7ay"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- ;; Sensible defaults: https://github.com/flame/libflame/issues/28
- (list "--enable-dynamic-build"
- "--enable-max-arg-list-hack"
- "--enable-lapack2flame"
- "--enable-verbose-make-output"
- "--enable-multithreading=pthreads" ; Openblas isn't built with openmp.
- ,@(if (any (cute string-prefix? <> (or (%current-target-system)
- (%current-system)))
- '("x86_64" "i686"))
- '("--enable-vector-intrinsics=sse")
- '())
- "--enable-supermatrix"
- "--enable-memory-alignment=16"
- "--enable-ldim-alignment")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-/usr/bin/env-bash
- (lambda _
- (substitute* "build/config.mk.in"
- (("/usr/bin/env bash") (which "bash")))
- #t))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (substitute* "test/Makefile"
- (("LIBBLAS .*") "LIBBLAS = -lblas\n")
- (("LIBLAPACK .*") "LIBLAPACK = -llapack\n"))
- (if tests?
- (with-directory-excursion "test"
- (mkdir "obj")
- (invoke "make")
- (invoke "./test_libflame.x"))
- #t)))
- (add-after 'install 'install-static
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (static (assoc-ref outputs "static")))
- (mkdir-p (string-append static "/lib"))
- (rename-file (string-append out "/lib/libflame.a")
- (string-append static "/lib/libflame.a"))
- (install-file (string-append out "/include/FLAME.h")
- (string-append static "/include"))
- #t))))))
- (inputs
- (list gfortran))
- (native-inputs
- `(("lapack" ,lapack)
- ("perl" ,perl)
- ("python" ,python-wrapper)))
+ (list #:configure-flags
+ ;; Sensible defaults: https://github.com/flame/libflame/issues/28
+ #~(list "--enable-dynamic-build"
+ "--enable-max-arg-list-hack"
+ "--enable-lapack2flame"
+ "--enable-verbose-make-output"
+ "--enable-multithreading=pthreads" ; Openblas isn't built with openmp.
+ #$@(if (target-x86?)
+ #~("--enable-vector-intrinsics=sse")
+ #~())
+ "--enable-supermatrix"
+ "--enable-memory-alignment=16"
+ "--enable-ldim-alignment")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-/usr/bin/env-bash
+ (lambda _
+ (substitute* "build/config.mk.in"
+ (("/usr/bin/env bash")
+ (which "bash")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (substitute* "test/Makefile"
+ (("LIBBLAS .*")
+ "LIBBLAS = -lblas\n")
+ (("LIBLAPACK .*")
+ "LIBLAPACK = -llapack\n"))
+ (when tests?
+ (with-directory-excursion "test"
+ (mkdir "obj")
+ (invoke "make")
+ (invoke "./test_libflame.x")))))
+ (add-after 'install 'install-static
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (static (assoc-ref outputs "static")))
+ (mkdir-p (string-append static "/lib"))
+ (rename-file (string-append out
+ "/lib/libflame.a")
+ (string-append static
+ "/lib/libflame.a"))
+ (install-file (string-append out
+ "/include/FLAME.h")
+ (string-append static "/include"))))))))
+ (inputs (list gfortran))
+ (native-inputs (list lapack perl python-wrapper))
(home-page "https://github.com/flame/libflame")
(synopsis "High-performance library for @acronym{DLA, dense linear algebra} computations")
(description "@code{libflame} is a portable library for dense matrix