summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-21 09:23:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:30 +0200
commit2ab298aefe64272f9be941166be7dd0e7302346e (patch)
tree7d707132a41fb5cfe6c94597b7a05cb12e7e1505
parent6bc38163153d5688b1b0e6acd648d63531841bcd (diff)
gnu: Add rust-wasm-streams-0.3.
* gnu/packages/crates-io.scm (rust-wasm-streams-0.3): New variable. (rust-wasm-streams-0.2): Inherit from rust-wasm-streams-0.3. Change-Id: I6b512a6849d32764025c9263a19c47ab4162d57a
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 30 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e2b668a7a5..891b7f9562 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -88363,8 +88363,37 @@ attribute that is not in the shared backend crate.")
(("rust-proc-macro2" ,rust-proc-macro2-0.4)
("rust-quote" ,rust-quote-0.6))))))
+(define-public rust-wasm-streams-0.3
+ (package
+ (name "rust-wasm-streams")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wasm-streams" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1iqa4kmhbsjj8k4q15i1x0x4p3xda0dhbg7zw51mydr4g129sq5l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.4)
+ ("rust-web-sys" ,rust-web-sys-0.3))
+ #:cargo-development-inputs (("rust-pin-project" ,rust-pin-project-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3)
+ ("rust-web-sys" ,rust-web-sys-0.3))))
+ (home-page "https://github.com/MattiasBuelens/wasm-streams/")
+ (synopsis "Bridge between web streams and Rust streams using WebAssembly")
+ (description
+ "Bridging between web streams and Rust streams using WebAssembly.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-wasm-streams-0.2
(package
+ (inherit rust-wasm-streams-0.3)
(name "rust-wasm-streams")
(version "0.2.3")
(source (origin
@@ -88373,7 +88402,6 @@ attribute that is not in the shared backend crate.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0y60yy64p07h684h49159hhws50q6zdnffyirjnjqcq87hvf7fkb"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-futures-util" ,rust-futures-util-0.3)
@@ -88385,11 +88413,7 @@ attribute that is not in the shared backend crate.")
(("rust-pin-project" ,rust-pin-project-1)
("rust-tokio" ,rust-tokio-1)
("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3)
- ("rust-web-sys" ,rust-web-sys-0.3))))
- (home-page "https://github.com/MattiasBuelens/wasm-streams/")
- (synopsis "Bridging between web streams and Rust streams using WebAssembly")
- (description "Bridging between web streams and Rust streams using WebAssembly")
- (license (list license:expat license:asl2.0))))
+ ("rust-web-sys" ,rust-web-sys-0.3))))))
(define-public rust-wasmparser-0.57
(package