summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-11-20 01:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:09 +0100
commit2bb8bf36a51326cfd6ca5099d0f668a642b67d88 (patch)
treeddb45de436cb367be7ff66a3d40046e8ec586972
parent831651f60bc6be57f1539d29f6bec17e3ea9db9e (diff)
gnu: powertop: Update to 2.15.
* gnu/packages/linux.scm (powertop): Update to 2.15. [arguments]: Don't explicitly return #t from phases. [native-inputs]: Add autoconf-archive.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0050132eea..135fb20999 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3151,7 +3151,7 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
(define-public powertop
(package
(name "powertop")
- (version "2.14")
+ (version "2.15")
(source
(origin
(method git-fetch)
@@ -3160,7 +3160,7 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1zkr2y5nb1nr22nq8a3zli87iyfasfq6489p7h1k428pv8k45w4f"))))
+ (base32 "10vbk4vplmzp3p1mhwnhj81g6i5xvam9pdvmiy6cmd0xvnmdyy77"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -3181,10 +3181,14 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
;; are missing powertop gracefully handles it.
(("/usr/bin/hcitool") "hcitool")
(("/usr/bin/xset") "xset")
- (("/usr/sbin/hciconfig") "hciconfig"))
- #t))))))
+ (("/usr/sbin/hciconfig") "hciconfig"))))))))
(native-inputs
- (list autoconf automake gettext-minimal libtool pkg-config))
+ (list autoconf
+ autoconf-archive
+ automake
+ gettext-minimal
+ libtool
+ pkg-config))
(inputs
(list kmod libnl ncurses pciutils zlib))
(home-page "https://01.org/powertop/")