summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-04-10 16:46:50 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-06-17 11:08:27 +1000
commit2e6973222d03200adb4c56adfd953aa46bba6e4c (patch)
treef3a0bb94a5a929e8f10305b85b6d7d278fead880
parent1ee4274c962b5b2cf1532b0fce20a27426b9d91a (diff)
gnu: Add python-bz2file.
* gnu/packages/python.scm (python-bz2file, python2-bz2file): New variables.
-rw-r--r--gnu/packages/python.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4f18680d4c..97f4e6cdb7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8766,6 +8766,43 @@ LDFLAGS and parse the output to build extensions with setup.py.")
(define-public python2-pkgconfig
(package-with-python2 python-pkgconfig))
+(define-public python-bz2file
+ (package
+ (name "python-bz2file")
+ (version "0.98")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bz2file" version))
+ (sha256
+ (base32
+ "126s53fkpx04f33a829yqqk8fj4png3qwg4m66cvlmhmwc8zihb4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; python setup.py test does not work as of 0.98
+ ;; but there is only the one test file
+ (replace 'check
+ (lambda _ (zero? (system* "python" "test_bz2file.py")))))))
+ (home-page "https://github.com/nvawda/bz2file")
+ (synopsis "Read and write bzip2-compressed files")
+ (description
+ "Bz2file is a Python library for reading and writing bzip2-compressed
+files. It contains a drop-in replacement for the I/O interface in the
+standard library's @code{bz2} module, including features from the latest
+development version of CPython that are not available in older releases.")
+ (license asl2.0)
+ (properties `((python2-variant . ,(delay python2-bz2file))))))
+
+(define-public python2-bz2file
+ (let ((base (package-with-python2
+ (strip-python2-variant python-bz2file))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools))))))
+
(define-public python-cysignals
(package
(name "python-cysignals")