summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-28 10:32:48 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:06 +0100
commit2ecb9af51c601287523b11c5f3c85d23d1d8fe9a (patch)
tree4945fe50597ca998d7de32d232c6797d946fbe8e
parent1e2d29ec719bae23bfd4f1d10a290f2bdad8bf2e (diff)
gnu: libkscreen: Enable all tests except for 5 failing.
* gnu/packages/kde-plasma.scm (libkscreen): Enable all tests except for 5 failing. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/kde-plasma.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 8d80a4686a..f7bc601ffb 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -265,6 +265,17 @@ call it if it is not associated to a terminal.")
(sha256
(base32 "17ib0sgrhmmf3f8w3fni0825xz5581av5vnz8gca41vyf12css25"))))
(build-system qt-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "WAYLAND_DISPLAY" "libkscreen-test-wayland-backend-0")
+ (invoke "ctest" "-E"
+ "(kscreen-testscreenconfig|kscreen-testqscreenbackend|kscreen-testkwaylandbackend|kscreen-testkwaylandconfig|kscreen-testkwaylanddpms)")))))))
(native-inputs
(list extra-cmake-modules
pkg-config
@@ -273,8 +284,6 @@ call it if it is not associated to a terminal.")
(inputs
(list kwayland libxrandr plasma-wayland-protocols
qtbase-5 qtwayland-5 wayland qtx11extras))
- (arguments
- '(#:tests? #f)) ; FIXME: 55% tests passed, 5 tests failed out of 11
(home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
(synopsis "KDE's screen management software")
(description "KScreen is the new screen management software for KDE Plasma