summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-03 19:27:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-11 18:13:44 +0200
commit2ffa3a400b6493330007928fc25af637488aa3bc (patch)
tree0dc23495f59e88624663261761b907596aeced95
parent64d97f28b19b7958ceafb1410ce3b53a20c60429 (diff)
gnu: texlive-latex-filecontents: Rename to texlive-filecontents.
* gnu/packages/tex.scm (texlive-filecontents): New variable. (texlive-latex-filecontents): Deprecate package. (texlive-latex-trimspaces): (texlive-latex-needspace): (texlive-latex-changepage): (texlive-ifmtarg): Apply renaming.
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8a44b09797..c81f9b1917 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3339,9 +3339,9 @@ a process to convert the EPS to PDF, using the script @command{epstopdf}.")
(define-deprecated-package texlive-latex-epstopdf-pkg texlive-epstopdf-pkg)
-(define-public texlive-latex-filecontents
+(define-public texlive-filecontents
(let ((template (simple-texlive-package
- "texlive-latex-filecontents"
+ "texlive-filecontents"
(list "doc/latex/filecontents/"
"source/latex/filecontents/"
"tex/latex/filecontents/")
@@ -3369,6 +3369,8 @@ overwrite existing files and letting you use @code{filecontents}
@code{filecontents*} anywhere.")
(license license:lppl1.3c+))))
+(define-deprecated-package texlive-latex-filecontents texlive-filecontents)
+
(define-public texlive-epsf
(package
(inherit (simple-texlive-package
@@ -5836,7 +5838,7 @@ be changed.")
(("pstool.tex") "trimspaces.tex"))
#t)))))
(inputs
- (list texlive-latex-filecontents))
+ (list texlive-filecontents))
(home-page "https://www.ctan.org/pkg/trimspaces")
(synopsis "Trim spaces around an argument or within a macro")
(description
@@ -9512,7 +9514,7 @@ and after the formatted number.")
'(#:tex-directory "latex/needspace"
#:tex-format "latex"))
(inputs
- (list texlive-latex-filecontents))
+ (list texlive-filecontents))
(home-page "https://www.ctan.org/pkg/needspace")
(synopsis "Insert pagebreak if not enough space")
(description
@@ -9538,7 +9540,7 @@ page, a new page will be started.")
'(#:tex-directory "latex/changepage"
#:tex-format "latex"))
(inputs
- (list texlive-latex-filecontents))
+ (list texlive-filecontents))
(home-page "https://www.ctan.org/pkg/changepage")
(synopsis "Margin adjustment and detection of odd/even pages")
(description
@@ -11718,7 +11720,7 @@ floats merely delays the arrival of the inevitable error message.")
(add-after 'unpack 'chdir
(lambda _ (chdir "source/latex/ifmtarg")))))))
(inputs
- (list texlive-latex-filecontents))
+ (list texlive-filecontents))
(home-page "https://www.ctan.org/pkg/ifmtarg")
(synopsis "If-then-else command for processing potentially empty arguments")
(description "This package provides a command for the LaTeX programmer for