summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-12 12:26:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-12 12:28:32 +0200
commit30ec6f2fb5bdac917df16d1efa122fad81518a0e (patch)
tree36f1dff41ed319c6cfd83bd9a7bc3d02a25e6da3
parente2a7c227dea5b361e2ebdbba24b923d1922a79d0 (diff)
gnu: macs: Update to 2.2.9.1.
* gnu/packages/bioinformatics.scm (macs): Update to 2.2.9.1. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Move python-cython from here... [inputs]: ...and python-numpy from here... [propagated-inputs]: ...to here.
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9500751a96..0df5bbfad5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7023,7 +7023,7 @@ experiments.")
(define-public macs
(package
(name "macs")
- (version "2.2.7.1")
+ (version "2.2.9.1")
(source (origin
;; The PyPi tarball does not contain tests.
(method git-fetch)
@@ -7033,7 +7033,7 @@ experiments.")
(file-name (git-file-name name version))
(sha256
(base32
- "08zsgh65xbpv1md2s3wqmrk9g2mz6izmn59ryw5lbac54120p291"))
+ "10vwc09fq4nvbd39hax1949mvq2wvkgz0k3p2zqmqwq8hv9r5l0j"))
(modules '((guix build utils)))
;; Remove files generated by Cython
(snippet
@@ -7048,21 +7048,17 @@ experiments.")
;; Python 3.10 is in fact more recent than 3.6.
(substitute* "setup.py"
(("float\\(sys.version\\[:3\\]\\)<3.6") "False"))))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-before 'build 'set-HOME
- (lambda _ (setenv "HOME" "/tmp")))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-v")))))))
- (inputs
- (list python-numpy))
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ ;; Propagate these for use of macs as a library.
+ (propagated-inputs
+ (list python-cython python-numpy))
(native-inputs
- (list python-cython python-pytest))
+ (list python-pytest))
(home-page "https://github.com/macs3-project/MACS")
(synopsis "Model based analysis for ChIP-Seq data")
(description