summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2024-03-07 14:43:06 -0500
committerAndreas Enge <andreas@enge.fr>2024-03-08 10:38:21 +0100
commit30fdec375490fdf56d8f5caeede102eb103193b7 (patch)
tree17716384670807e26163eed7b25860723f052183
parent906f380f7cd0570e253bc7affc90077f62e98528 (diff)
gnu: Add rdate.
* gnu/packages/time.scm (rdate): New variable. Change-Id: I12217c62fe17a93bdb5364f807804eea7fc57a23 Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/time.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index b0d800da94..0bb493c27f 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -40,6 +40,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages time)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -549,6 +550,30 @@ datetime type.")
"This package contains a library for parsing ISO 8601 datetime strings.")
(license bsd-3)))
+(define-public rdate
+ (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+ (revision "1"))
+ (package
+ (name "rdate")
+ (version (git-version "1.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/njh/rdate")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake))
+ (synopsis "Get date and time based on RFC 868")
+ (description
+ "@code{rdate} connects to an RFC 868 time server over a TCP/IP network,
+printing the returned time and/or setting the system clock.")
+ (home-page "https://www.aelius.com/njh/rdate/")
+ (license gpl2+))))
+
(define-public datefudge
(package
(name "datefudge")