summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-10-06 17:17:11 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-10-09 00:05:57 -0400
commit321979a15317eaf93b15e9cca30d328d39cca4b1 (patch)
treea16d52718adb02ac6400d6067bcf8a4bc921b55d
parent40a1254b05612759e919507c9201d7cd291d5975 (diff)
gnu: imgui@1.86: Adjust make-flags.
* gnu/packages/toolkits.scm (imgui-1.86)[arguments]: Remove the "-DIMGUI_ENABLE_FREETYPE" make-flag which breaks the display of mangohud, the only dependent. The "-DImDrawIdx=unsigned int" make-flag was previously removed, so we can do both by filtering make-flags starting with "-D". [inputs]: Remove freetype.
-rw-r--r--gnu/packages/toolkits.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index 15918467aa..9d002ecab1 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -173,6 +173,11 @@ standard operating system features.")
(arguments
(substitute-keyword-arguments (package-arguments imgui)
((#:make-flags flags ''())
- ;; Remove the "-DImDrawIdx=unsigned int" make-flag as this breaks
- ;; mangohud, the only user of this version.
- #~(delete "-DImDrawIdx=unsigned int" #$flags))))))
+ ;; Remove "-DImDrawIdx=unsigned int" and "-DIMGUI_ENABLE_FREETYPE"
+ ;; from make-flags as this breaks MangoHud, the only user of this
+ ;; version.
+ #~(filter (negate (lambda (x) (string-prefix? "-D" x)))
+ #$flags))))
+ (inputs
+ (modify-inputs (package-inputs imgui)
+ (delete "freetype")))))