summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Antoine Rouby <contact@parouby.fr>2018-10-25 12:28:16 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-26 21:16:13 +0200
commit3239dcd38d28d6a34338a9c1a1ddad42a326f7a2 (patch)
tree0586b2b84df89d91df863560d66ef7aa56ca5e5f
parentfdf02484289e155de56e7320f7e1dd1e57431f4b (diff)
gnu: Add jp2a.
* gnu/packages/image.scm: New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/image.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b367e0799c..9bf9bd7e5e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
@@ -1497,3 +1499,30 @@ Two other programs are included with Gifsicle: @command{gifview} is a
lightweight animated-GIF viewer, and @command{gifdiff} compares two GIFs for
identical visual appearance.")
(license license:gpl2+)))
+
+(define-public jp2a
+ (package
+ (name "jp2a")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cslarsen/jp2a/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nahpjvrahixcfqqrjj2k4fscc8qs4hqnmj2qgjzsjj3z6xxh2g5"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("curl" ,curl)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://csl.name/jp2a/")
+ (synopsis "Convert JPEG images to ASCII")
+ (description
+ "Jp2a is a small utility that converts JPEG images to ASCII.")
+ (license license:gpl2)))