summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-03-08 21:23:27 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-16 22:59:47 +0000
commit32fd2776429b5cd1fb5094532f490e5d31415f6e (patch)
tree8945e876f1ea4a2861e10266186e92e9f5e78fe6
parente1e65c593009bfb564e6f2a684e4300d058d1e0d (diff)
gnu: Add go-github-com-jbenet-go-random.
* gnu/packages/golang-xyz.scm (go-github-com-jbenet-go-random): New variable. Change-Id: I7b7f510af61f4bf79aa633ffaa4bd4852f55fc47 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3f5cdc404d..cd3fbb8098 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1035,6 +1035,32 @@ increment versions.")
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-jbenet-go-random
+ (package
+ (name "go-github-com-jbenet-go-random")
+ (version "0.0.0-20190219211222-123a90aedc0c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/go-random")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kgx19m8p76rmin8s8y6j1padciv1dx37qzy7jkh9bw49ai3haw3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/go-random"))
+ (propagated-inputs
+ (list go-github-com-dustin-go-humanize))
+ (home-page "https://github.com/jbenet/go-random")
+ (synopsis "Go library and a program that outputs randomness")
+ (description
+ "This is a Unix utility that outputs randomness. It is a thin
+wrapper around @code{crypto/rand}.")
+ (license license:expat)))
+
(define-public go-github-com-jbenet-go-temp-err-catcher
(package
(name "go-github-com-jbenet-go-temp-err-catcher")