summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-06-16 00:37:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-06-16 22:54:56 +0200
commit360a9f0a2f94053ad11bcec43710ef68660082e9 (patch)
tree1da4ba7bda489d70e8667fd71a15f274bad4d1a6
parentb345a5e17f60e1cf700980e608a5b33e51062978 (diff)
gnu: Add python-scikit-survival.
* gnu/packages/python-science.scm (python-scikit-survival): New variable. Change-Id: I657f5d737280cac74f93f7f3d2b56a9a0a41588e
-rw-r--r--gnu/packages/python-science.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 39ba0dad96..30f540e05b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -582,6 +582,63 @@ implements several methods for sequential model-based optimization.
@code{skopt} aims to be accessible and easy to use in many contexts.")
(license license:bsd-3)))
+(define-public python-scikit-survival
+ (let ((revision "1")
+ ;; We need a later commit for support of a more recent sklearn and
+ ;; numpy 2.
+ (commit "bceb53ebb8306f959c70fae2be9d552f33dd3f21"))
+ (package
+ (name "python-scikit-survival")
+ (version (git-version "0.22.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sebp/scikit-survival")
+ (commit commit)
+ ;; This package contains a copy of Eigen. It would be good to
+ ;; figure out how to use our own Eigen package.
+ (recursive? #true)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m3z64nv4sgay0mdrrw4q4z5ylx63a9w2x43w1r4g8kpg7z9rdfc"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
+ #$(version-major+minor version)))))))
+ (propagated-inputs
+ (list python-ecos
+ python-importlib-resources
+ python-joblib
+ python-numexpr
+ python-numpy
+ python-osqp
+ python-pandas
+ python-scikit-learn
+ python-scipy))
+ (native-inputs
+ (list python-black
+ python-pypa-build
+ python-coverage
+ python-cython-3
+ python-packaging
+ python-pytest
+ python-setuptools-scm
+ python-tomli
+ python-tox))
+ (home-page "https://github.com/sebp/scikit-survival")
+ (synopsis "Survival analysis built on top of scikit-learn")
+ (description "Scikit-survival is a Python module for survival analysis
+built on top of scikit-learn. It allows doing survival analysis while
+utilizing the power of scikit-learn, e.g., for pre-processing or doing
+cross-validation.")
+ (license license:gpl3+))))
+
(define-public python-tdda
(package
(name "python-tdda")