summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-12-18 13:46:56 -0500
committerLudovic Courtès <ludo@gnu.org>2022-12-27 23:53:42 +0100
commit361aad5ce33afeefa269533c33141fc77f74837c (patch)
treeeb9f062394e959acabdeb2860a3ec957e5f013a8
parent5f8a51993e95775f5b2b753f709c8047d05c963e (diff)
gnu: ola: Use gexps.
* gnu/packages/lighting.scm (ola)[arguments]: Use gexps. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lighting.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index d0ad825d10..6230963a4b 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages lighting)
#:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -67,10 +68,11 @@
(propagated-inputs
(list protobuf)) ; for pkg-config --libs libola
(arguments
- `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
- ;; build to fail on low memory systems. We disable that with the
- ;; following configure flags.
- #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
+ (list
+ ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
+ ;; build to fail on low memory systems. We disable that with the
+ ;; following configure flags.
+ #:configure-flags #~(list "CXXFLAGS=-ftrack-macro-expansion=0")))
(synopsis "Framework for controlling entertainment lighting equipment")
(description "The Open Lighting Architecture is a framework for lighting
control information. It supports a range of protocols and over a dozen USB