summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-06 10:28:02 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-19 21:51:06 +0100
commit369d0e7f5c7d5b81543bc053ea9a51fd921102ec (patch)
tree4d678e6811798dcc3c0d6de574298a43f56838f8
parentef2b9322fae1d03bf639924d12214b0f58c11054 (diff)
gnu: Add git2cl.
* gnu/packages/version-control.scm (git2cl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/version-control.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 7c93337625..137c7c8336 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2021 Léo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -600,6 +601,31 @@ everything from small to very large projects with speed and efficiency.")
("perl" ,perl)
("zlib" ,zlib)))))
+(define-public git2cl
+ (let ((commit "1d74d4c0d933fc69ed5cec838c73502584dead05"))
+ (package
+ (name "git2cl")
+ (version (string-append "20120919." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.nongnu.org/git/git2cl.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wnnbm2sjvfj0qrksj89jlnl69miwl0vk3wrrvgvpclgys3na2g1"))))
+ (build-system copy-build-system)
+ (inputs
+ `(("perl" ,perl)))
+ (arguments
+ `(#:install-plan '(("git2cl" "bin/git2cl"))))
+ (home-page "https://savannah.nongnu.org/projects/git2cl")
+ (synopsis "Convert Git logs to GNU ChangeLog format")
+ (description "@code{git2cl} is a command line tool for converting Git
+logs to GNU ChangeLog format.")
+ (license license:gpl2+))))
+
(define-public gitless
(package
(name "gitless")